25.10 Latest Software Release (US)

Scheduled for Apr 3, 04:00 - 06:00 EDT

Update

The scheduled maintenance has been rescheduled to Thursday March 3
Posted Apr 01, 2025 - 17:13 EDT

Scheduled

Latest software release will be deployed during this maintenance window.

Please follow this link for updates: https://status.paytronix.com

If you have any questions, please contact Paytronix at support@paytronix.com or 1-866-PXHELPME (866-794-3576) #1
Posted Mar 27, 2025 - 11:20 EDT
This scheduled maintenance affects: Paytronix US (Transactional Email Servers, Transaction Processing, Apps/Integrations/APIs, Messaging, Guest Website, Merchant Website, Analytics, Bulk Email Processing, Bulk Email Servers (Delivery to Guests), Scheduled Reports).