Delayed Reporting for a Small Subset of Customers

Incident Report for Paytronix

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 17:57 EDT

Identified

We have identified that a small subset of customers are seeing reports where the data being displayed is behind by several days. Our engineers are working to get the reports resynchronized.
Posted Oct 13, 2025 - 14:53 EDT
This incident affected: Paytronix US (Analytics, Scheduled Reports).