Increased Latency Due to Third Party Provider

Incident Report for Paytronix

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 16:41 EDT

Identified

We are working with our third party provider and are monitoring the situation. Affected customers may see prolonged transaction processing times.
Posted Aug 21, 2025 - 14:20 EDT
This incident affected: Paytronix US (Transaction Processing, Apps/Integrations/APIs, Online Ordering).