Service Degredation due to Cloudflare Outage

Incident Report for Paytronix

Resolved

The ongoing incident with Cloudflare has been resolved and there is no lingering impact on customers.
Posted Nov 18, 2025 - 13:08 EST

Update

Cloudflare is still in the process of recovering, though service has improved. We are closely monitoring the situation and will continue to restore functionality as Cloudflare’s recovery progresses.
Posted Nov 18, 2025 - 11:39 EST

Monitoring

Cloudflare reported resolving this issue, we are seeing systems return to normal function. We will continue to monitor for stability and resolve any residual issues.
Posted Nov 18, 2025 - 09:48 EST

Identified

We are aware of the current Cloudflare outage, our services are operating normally, but a small subset of customers may experience connectivity issues.

As Cloudflare continues to recover, connectivity issues will recover as well.
Posted Nov 18, 2025 - 09:15 EST
This incident affected: Paytronix US (Transaction Processing, Apps/Integrations/APIs, Messaging, Guest Website, Merchant Website, Analytics, Online Ordering, Mobile Apps - Android, Mobile Apps - iOS) and Paytronix Europe (Apps/Integrations/APIs, Messaging, Guest Website, Merchant Website, Analytics).