Reporting and Online Ordering is experiencing degraded performance due to the AWS outage

Incident Report for Paytronix

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:34 EDT

Update

Our services continue to recover as the AWS recovery continues. We continue to monitor AWS' recovery, and will continue to update as we see restoration of services.
Posted Oct 20, 2025 - 17:14 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:03 EDT

Identified

We are monitoring the AWS outage and will provide further updates as we receive them.
Posted Oct 20, 2025 - 09:58 EDT
This incident affected: Paytronix US (Merchant Website, Analytics, Online Ordering, Scheduled Reports).