Transaction Processing Errors

Incident Report for Paytronix

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 22:53 EDT

Monitoring

We have implemented a fix and are monitoring. This incident impacted a small subset of merchants
Posted Aug 19, 2025 - 21:57 EDT

Identified

We are aware of elevated error rates around some transactions. We are implementing a fix
Posted Aug 19, 2025 - 21:34 EDT
This incident affected: Paytronix US (Transaction Processing).