Campaign Center Execution Degraded

Incident Report for Paytronix

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 17:45 EST

Identified

The issue with the Campaign Center has been identified and a solution is being implemented.
Posted Nov 07, 2025 - 16:29 EST

Investigating

We are currently investigating an issue with the Campaign Center where customers are seeing significant delay in campaign execution.
Posted Nov 07, 2025 - 16:25 EST
This incident affected: Paytronix US (Transaction Processing).